GDM can be installed with the gdm package, and it is installed as part of the gnome group.If you would prefer to use legacy GDM which was used in GNOME 2 and has its own configuration utility, install the gdm-oldAUR package. 13. Next step is to enable then start and test GDM by logging to Arch Linux using your credentials. 2. slim work well with gnome-shell. I have installed GDM along with Gnome and I have enabled the GDM service, but GDM just doesnt start. I think that openSUSE and Fedora may offer an ARM-based solution that would provide Gnome out of the box. This does unfortunately not work. You might also need the Gnome Display Manager (gdm) package to launch the desktop environment. SuSE 6.3 : Gnome Display Manager gdm not starting. So it will find the "enabled" /etc/systemd/system/display-manager.service and run that. 12. GDM - the Gnome Display Manager - is designed for use with Gnome 3. Couldn’t install shortcut for MediaPlayPause. Edit: Nevermind, I now see that you checked to see that it s running. Just got my Acer Aspire 1410 and decided to install Arch like on my previous laptop and this time I decided to use GNOME as desktop environment. I am honestly at a loss with this. start dbus # rc.d start dbus. I did follow the really good(!) So using GDM.service is likely not going to work, as most service files are all lower case. @Strike0,Just to note that the first of those links is not necessary i.e. GDM crashes when attempting to launch a GNOME Wayland session. # pacman -S os-prober # grub-mkconfig -o /boot/grub/grub.cfg I am not entirely sure what to look for, at least nothing strikes out to be as broken right away. You can specify which programs to start automatically after login using the gnome-session-properties tool, which is a part of the gnome-session package. Yo T vi salir campeón InTrnacional, yo T di la vuelta en la cara y vi como lloraste y T paraste a aplaudirme. Start program automatically after login to GNOME 3. After that, you should create the bootable flash drive with the Arch Linux image. In the case of gdm.service (as well as other display managers), they are aliased to display-manager.service. Run the following command to install GDM display manager package. It's working (writing from Epiphany right now), but when I start GDM nothing happens, it just starts X (and displays a cursor in the middle) and then freezes and does nothing.. So recreating it allowed to to fix it and point to the correct destination. QApplication: invalid style override ‘gtk’ passed, ignoring it. Thank you very much. Start GDM and login with your user. Problem: GDM is crashing when attempting to launch a GNOME Wayland session. Look through the journal to see if there are some clues as to why it is not starting. I still get dropped to the command line on boot. The new setting will take effect after restarting the GDM service. Step 4: Let Arch Linux start back up. the default.target -> .../graphical.target one. The standard target is default.target, which is a symlink to graphical.target. If you have a dual-boot system, you may need to switch to Arch Linux by restarting your computer, selecting Arch Linux when prompted, and pressing ↵ Enter. The GDM configuration file contains a command in the [server-Standard] section that is used for starting the Xserver. If you have gnome installed does starting wayland on the command line work, not using GDM? All times are UTC . After upgrade to [gnome-unstable],System hangs when starting gdm.service. Then i moved ahead to installing xorg and gnome It was also completed with no errors. There are other ways to get Gnome on the Pi. Board index » Linux. The display-manager.service is crucial, though. https://wiki.archlinux.org/index.php/Sy … ing_output. If you’re using Linux distro other than Arch CLI then it’s one of the toughest tasks to setup WiFi on Arch Linux using the terminal. When it finishes starting up, you’ll see LightDM appear as the new login screen. Known to affect at least gdm-3.32.0. Last edited by Strike0 (2013-06-30 08:04:38), Try doing thishttps://bbs.archlinux.org/viewtopic.php … 7#p1294407, bitcoin: 1G62YGRFkMDwhGr5T5YGovfsxLx44eZo7U. I have installed arch, lastest gnome 3.10, lxde, xfce and I use GDM. If I login and start GDM … But, 1. Switched back to gdm.service … I've checked the logs (journalctl -u gdm) and when starting gdm manually with systemctl, I see some messages I haven't seen before: Jan 23 20:24:15 archlinux gdm[15454]: Child process -28330 was already dead. gdm-restart stops and restarts GDM by sending the GDM daemon a HUP signal. But here, I choose to install GDM (Gnome Display Manager). If I login and start GDM as. This roughly corresponds to the old runlevel 5. Now, you can install GNOME desktop environment on Arch Linux using: pacman -S gnome. It freezes with a blank screen. Re: GNOME 3.36 shell/mutter/etc not starting GS 3.36 is working OK with Testing / Community-Testing enabled and has been for a few days now. Step 3: Reboot your Arch Linux PC using the systemctl reboot command. Step 6: Finally, reboot the system and use your existing Arch Linux login credentials to log in to your newly Graphical user interface Linux. systemctl start gdm.service systemctl enable gdm.service systemctl enable NetworkManager.service. Every time I boot I end up at a tty login. It's working (writing from Epiphany right now), but when I start GDM nothing happens, it just starts X (and displays a cursor in the middle) and then freezes and does nothing.. The latest package versions gdm-plymouth 3.36.3-3, libgdm-plymouth 3.36.3-3, plymouth 0.9.5-4 are starting again without problems. I have googled around to try and find some answers and I have tried everything I have found (enabling early KMS with nvidia drivers, setting the GDM service to have Idle type, disabling the wayland backend), nothing has worked. The main card on the box is Geforce GTX1080TI. So using GDM.service is likely not going to work, as most service files are all lower case. The new setting will take effect after restarting the GDM service. Do ctrl+alt+F1 then F2, etc. systemctl start gdm.service. If none of these are in error, what could be stopping GDM from starting on boot? When the graphical.target is enabled, or booted to, it pulls in the display-manager.service as a dependency (Wants=display-manager.service). I did a fresh arch uefi install and everything went smoothly. If your computer is plugged into your router via ethernet, you can skip this step. ; Type pacman -S iw wpa_supplicant and press ↵ Enter to install the necessary software. Please help me im stuck in try. Start and enable GDM. Hello everyone i just switched to arch 2 days ago after years of Windows. # systemctl start ModemManager. cfr, good to clarify, yes. arguements too long. When you "enable" a service, systemctl parses the [Install] section of the systemd.service, and uses that information to determine what it will do. Specifically for those using Gnome 3. 4. Posted by 3 days ago. I recently did a fresh install of Arch on a new machine. Starting your desktop. have a look at, for any non-active ones. If I go back to the text console and run sudo systemctl start alsa-restore Again, all is well in the text console until I login with GDM. Presently this package is incompatible to support Nvidia Optimus setups However, according to the wiki, GDM should automatically unlock my keyring, even on auto-login, but this is not … We can start using Arch Linux 2016 with Budgie Desktop. I used an USB Live CD to start. If you restart your computer, you will have to enter your username and password to log into Arch Linux before continuing. Like: How could I help more for fix this bug? 12. The GDM wiki page and the GDM package both make no mention of having plymouth and rc-local as dependencies. I have 2 GPUs (already tried removing one of the GPUs and gdm is still not starting). I managed to get the systemd version of LFS and BLFS installed. Then start gnome display manager service to use gnome DE using following commands. If anyone feels bored you can straight head to my next question. Known to affect at least gdm-3.32.0. Last edited by talleres (2013-07-01 18:26:01). Well.. I just have removed gdm (which was installed near gdm3 after updated my system from 16.04 to 18.04) sudo apt purge gdm Remember that you can login without X environment on Linux system : Just press Ctrl+Alt+F2 (or any other Fn except F1 or F7) to access a login console. And Arch Linux is … So you may need to go remove the symlink manually in /etc/systemd/system, which should be a symlink called display-manager.service that points to gdm.service. Today, when trying to turn on my computer, gdm wouldn't start resulting in a black screen. However, starting GDM mutes my sound card. systemctl start gdm.service systemctl enable gdm.service. ... SuSE 6.3 : Gnome Display Manager gdm not starting... messages elided ... Maybe me. Then we have to add windows to grub boot loader. However, if you have a problem different from the one discussed in this thread, I suggest starting your own thread because this one is marked as [solved] and is therefore unlikely to attract much further attention. I tested this guide in latest Arch Linux version, and I hope this will work on other Arch-based systems such as Antergos, Manjaro Linux etc. Ubuntu sudo apt install gdm3 Debian sudo apt-get install gdm3 Arch Linux sudo pacman -S gdm Fedora sudo dnf install gdm OpenSUSE sudo zypper install gdm. Now when I run: systemctl start gdm The system Also tried lower resolutions and VESA. Presumably, the symlink must have somehow been borked, or pointed to the wrong place. March 10, 2020, 3:01pm #1. GDM Killed at Startup I have attempted the suggestions there with: sudo apt-get install -f -m --reinstall -u gdm The log reports: 0 upgraded, 0 newly installed, 1 reinstalled, 0 to remove and 0 not upgraded Do you want to continue [Y/n] Y A bit more logging and end with: Setting up gdm (2.30.2 is.2.30.0-0ubuntu5.2 ... Next per the suggestion: The display manager aliases itself to display-manager.service, then by making the graphical.target the default.target, the (now aliased) display-manager.service is pulled in as a "Wants=" of the graphical.target. $ sudo pacman –S gdm. I thought not to take the obvious Windows CD's (little sorrow now) and try Linux. DAEMONS=...dbus. Be sure to save anything you’re working on before entering the command! As I encrypted my root and home partitions, I decided to use auto-login this time and have only one password to type. How To Ask Questions The Smart Way | Help Vampires, Arch Linux | x86_64 | GPT | EFI boot | refind | stub loader | systemd | LVM2 on LUKSLenovo x270 | Intel(R) Core(TM) i5-7200U CPU @ 2.50GHz | Intel Corporation Wireless 8265 / 8275 | US keyboard with Euro | 512G NVMe INTEL SSDPEKKF512G7L. Last edited by KaiKratz (2013-06-30 21:25:21), HI, welcome to the forums. As expected it did not matter. That all looks legit. Next step is to install GDM display manager package which helps system to start X server and provides a Graphical User Interface for users to login to Cinnamon DE. $ sudo systemctl enable gdm $ sudo systemctl start gdm. $ sudo systemctl enable gdm $ sudo systemctl start gdm. Then he used systemctl to re-enable the gdm.service. For example, I do not have a default.target set there at all because I just use systemd's builtin default. Are they meant to be dependencies or is the service file in error? guides and got all stuff up and running without any issues. Nesse sequencia do vídeo da instalação do Arch Linux vamos instalar a DE(Desktop) e a DM(Desktop Manager) para usar a unidade gráfica. I enabled graphical only to see if it makes a difference at all for gdm, since KaiKratz obviously has it enabled. This brief tutorial describes how to install GNOME desktop environment in Arch Linux. The version installed is: telegram-desktop 0.6.7. Once you have verified that it actually works you can make gdm start up at boot: rc-update add gdm So you may need to go remove the symlink manually in /etc/systemd/system, which should be a symlink called display-manager.service that points to gdm.service. Running this command from the console should start the Xserver. The last step includes enabling the display manager GDM for Arch. Well.. On Arch Linux ARM's console fw_setenv does the same thing. Does 'File exist" imply in this context that the service is already 'enabled' to be run on every boot? So what KaiKratz did was manually delete the symlink /etc/systemd/system/display-manager.service. So first remove "/etc/systemd/system/display-manager.service" and then I enable gdm.service with "systemctl enable gdm.service"? There are several Display Manager available. Nothing more? The Archlinux ARM Rollback is up again (I don't know for how long though). Hi. The application does not start: FT_New_Face failed with index 0 : 1 FT_New_Face failed with index 0 : 1 FT_New_Face failed with index 0 : 1 FT_New_Face failed with index 0 : 1. Note: Newer GDM packages ship with Xwayland as the default display server backend. I also installed xfce4 and the proprietrary nVidia driver. SuSE 6.3 : Gnome Display Manager gdm not starting . Hi, sorry I do not understand the solution, would kindly explain the steps that led to this solution? Use following commands to do so. The good news is that you do not need to get to the U-boot prompt, it's good for testing and rescue purposes, but in general U-Boot settings are stored on the NAND. I am new to LFS but not new to Linux, having successfully set up Fedora, Gentoo, Arch Linux, and Debian in a multiboot environment. [[email protected]:~]# pacman &ndash S gdm. That won't work. This command will immediately terminate all sessions and log out users currently logged in with GDM. [[email protected]:~]# systemctl start gdm [[email protected]:~]# systemctl enable gdm. If you can deduce a problem from this output can you please be so kind and hint me into the right direction? I … Prior to that it was broken ("something's gone wrong"); probably mutter as Budgie failed in the same way. (almost default.. since I used the DAEMONS-array in rc.conf to start GDM, and now use it to start SLiM) And my .xinitrc says "exec ck-launch-session startlxde" since I've been using SLiM + LXDE + Compiz for the last couple of days (without any problems...), btw as far as I know GDM … Now exit from chroot using the exit command: exit So the second symlink is the one in focus indeed. Switched back to gdm.service … Also, Linux is case-sensitive. add dbus to the daemons vi /etc/rc.conf the last line. I have a new install of arch on my laptop. The last step includes enabling the display manager GDM for Arch. In this article, I’ll walk you newbies through the step-by-step setup guide to connect your Arch Linux to your WiFi network. I also suggest enabling Network Manager. So, I boot up off a live disc, disable the GDM service reboot back into shell and start looking around. Setting the default target to graphical.target fixed the issue. I tried to install cinnamon and when I try to start it, There's nothing on my screen. Be sure to save anything you’re working on before entering the command! On the U-Boot prompt you would use setenv to make changes and saveenv to save them permanently. Every time I boot I end up at a tty login. Now, you can install GNOME desktop environment on Arch Linux using: pacman -S gnome. Thanks for this information, lots of digging around to why GDM would not start! Arch Linux is not for Linux beginners; there's a lot of manual configuration and command line work involved that Linux rookies probably aren't comfortable with. Should that have been set automatically by something? Then have a look at your output of. I was able to start it manually by running "sudo systemctl stop gdm && sudo systemctl start gdm" Additional info: * package version(s): 3.18.0-1 Steps to reproduce: - Install Arch with gdm and nvidia proprietary drivers - reboot and see gdm not starting at boot reboot So if your issue is the exact same as the OP, then yes, that is what solved it. I don't understand this. Problem: GDM is crashing when attempting to launch a GNOME Wayland session. GDM crashes when attempting to launch a GNOME Wayland session. Please remember to mark your thread as [Solved] by editing your first post and prepending it to the title. Set up a Wi-Fi connection. Linux. Most likely you saw at least some info here: XDG_SESSION_TYPE=wayland dbus-run-session gnome-session ... Arch Linux: GRUB does not load after installation. Auto-login works fine. "#systemctl start gdm.service" could start gdm ,after run startx to exec awesome and quit. [SOLVED] Gnome (GDM) wont auto start on boot, https://bbs.archlinux.org/viewtopic.php … 7#p1294407. As you can see in #2, I use default too. So it looks for that service in the usual places and runs that, whatever it is. Or did i maybe overlook any configuration step? If I have this problem, but it turns out that now I have another because "gdm" takes way too to start. I can run GDM with 'systemctl start gdm.service' from there everything runs fine. You are therefore advised to uncomment #WaylandEnable=false setting in /etc/gdm/custom.conf in order to proceed. First of all, you need the Arch Linux image, that can be downloaded from the Official Website. Hi. Install the LTS kernel. The Arch Linux installation image has been refreshed today and it’s the first to be powered by the latest Linux kernel 5.9 series and also offer new accessibility features. Now exit from chroot using the exit command: exit $ gnome-session-properties. @OP,Incidentally, the output you are posting suggests you are trying to enable gdm as a regular user. Did it fail, or did it every try to load at all? Open up a terminal and use the commands that match your Linux OS to get it going. I also suggest enabling Network Manager. @talleres, I don't really know what your issue is, or if it is the same as what was discussed in this thread. Whether or not i will solve your problem, I have no idea. Couldn’t install shortcut for MediaPreviousTrack. When it finishes starting up, you’ll see LightDM appear as the new login screen. Just got my Acer Aspire 1410 and decided to install Arch like on my previous laptop and this time I decided to use GNOME as desktop environment. Step 5: Once the downloading and setting up of GNOME DE is done, use this command to start and enable gnome display manager for Arch Linux. In our previous post, we did show you how to install Arch Linux, if you want to install Gnome or Kde, please use the following steps: 1 ... you can change gdm with kdm if you like it. Instalação em menos de 5 … Using ethernet is preferable to using Wi-Fi.. CentOS 5 :: GDM Not Starting Automatically On CentOS 5.4? # systemctl enable gdm # systemctl start gdm. This is likely not a gdm-old issue, therefore stating "gdm-old is broken", per below is incorrect. I tried all the startup options like apci=off and so on. How should gdm be starting its own pulseaudio process? Well.. I did opt to install GNOME as GM and followed the guide to set things up using 'systemctl enable gdm.service' to set GDM to start on boot. But what I described is what solved the issue for the OP. Of course I start in the obvious /var/logs. However, rc-local.service and plymouth-start.service dont exist on my system (neither does plymouth-quit.service which is mentioned in another part of the GDM service file). Any hints as to what I should look for? GDM Killed at Startup I have attempted the suggestions there with: sudo apt-get install -f -m --reinstall -u gdm The log reports: 0 upgraded, 0 newly installed, 1 reinstalled, 0 to remove and 0 not upgraded Do you want to continue [Y/n] Y A bit more logging and end with: Setting up gdm (2.30.2 is.2.30.0-0ubuntu5.2 ... Next per the suggestion: wiki; g14-and-g15; setup-guides; arch-full-guide $ Arch linux Arch Installation Walkthrough:warning: WARNING: this guide is out of date, deprecated, and no longer supported.Fedora Workstation v33+ is now the recommended distribution for G14 and G15 laptops Arch Linux does not include an installer program that automates installation, and instead relies on a manual installation procedure. Well this solved my Manjaro issue! rc-service gdm start. Now installing Arch Linux is completed. GDM does not start on boot: I'm having same problem I also read tis problem that you solved before, I tried that but got nothing. yes, try the bit WonderWoofy explains in the first para. I can launch xfce from the command line using 3.1.0 is out. Also, Linux is case-sensitive. It's working (writing from Epiphany right now), but when I start GDM nothing happens, it just starts X (and displays a cursor in the middle) and then freezes and does nothing.. At this point, we now have Budgie Desktop and GDM Login installed. 1. @KaiKratzCould you post the output of 'systemctl status gdm.service'? This brief tutorial describes how to install GNOME desktop environment in Arch Linux. Please help me im stuck in try. Type ip link and press ↵ Enter to determine the interface name of your network adapter. 615. I DO NOT WANT Wayland ! Still not working for me on Arch. I am expecting to hear Orca speaking at this point, but I hear nothing. Related articles. If you're on a GNU/linux distribution, you can use the dd command for it. Still no luck. Open up a terminal and use the commands that match your Linux OS to get it going. Same issue here. Edit:Solution was to Unlink /etc/systemd/system/display-manager.service and the again enabling gdm service with systemctl enable gdm.serviceUnfortunately I was unable to identify the root cause for this problem. GDM does not start on boot: I'm having same problem I also read tis problem that you solved before, I tried that but got nothing. Start Kdm or gdm to get the screen bellow. I am unsure why NetworkManager gets away with this. Log in to Arch Linux. Arch Linux has a "single point of failure"? I already tried removing one of the GPUs and booting the system with just one of the cards. Start gdm service and enable it on every boot. Note that the rest of this article discusses current GDM, not legacy GDM, unless indicated otherwise.You might also wish to install the following: 1. gdm3setup — An interface to configure GDM3, autologin options and change Shell theme You need a user other than root for this to succeed, since GDM will refuse starting if no user accounts (meaning accounts with a UID >= 1000) are available. View Entire Discussion (4 Comments) More posts from the archlinux community. And if enabling it succeeds, the default runlevel will be graphical.target --> gdm. Ubuntu sudo apt install gdm3 Debian sudo apt-get install gdm3 Arch Linux sudo pacman -S gdm Fedora sudo dnf install gdm OpenSUSE sudo zypper install gdm. If you’ve been waiting to install the famous Arch Linux distribution with the latest Linux 5.9 kernel series, the wait is finally over. FS#63706 - [gdm] Gdm will not start due to gdm used created by systemd-sysusers . Next step is to install GDM display manager package which helps system to start X server and provides a Graphical User Interface for users to login to Cinnamon DE. Downgrading back to version 0.15.0-2, as suggested in my post above, indeed, solved the issue (don't forget to also install the xf86-video-fbdev package, without it SDDM won't start). A Login window prompts, select user and hit Sign In. Verify that this command works on your system. I have a new install of arch on my laptop. In there are all old logs, but they are all dated back in 2014, probably when I … To set up GDM as your default display manager on Linux, you must first install it. I would look back through your shell history and see that you didn't set it to multi-user at some point. Working from the command line in a text-only console using espeakup, all is well, and sound works as it should. My system is Arch Linux: Linux 3.17.2-1-ARCH #1 SMP PREEMPT Thu Oct 30 20:49:39 CET 2014 x86_64 GNU/Linux Step 4: Let Arch Linux start back up. 3. journalctl is empty. Oct 31, 2009. this is probably something trivial but how can I auto start gdm on CentOS 5.4? Okey I'm just kidding! The first thing to do after installing Arch Linux is to install the LTS (long-term support) kernel, which is recommended installing if you want to make your Arch system more stable.The LTS kernel gets less frequent updates but it is patched with all the security fixes. I was just having a look at the GDM systemd service file and I noticed this line. Did I understood the documentation correct that a single call to 'systemctl enable GDM.service' should set systemd to execute the GDM on every boot? The latest package versions gdm-plymouth 3.36.3-3, libgdm-plymouth 3.36.3-3, plymouth 0.9.5-4 are starting again without problems. cris_su. systemctl enable gdm.service. Can you do either just "systemctl" without any arguments, or do "systemctl --type=service" to see if GDM made an attempt at loading? There is lot more tweaks at Arch Linux Wiki about gnome 3. I tested this guide in latest Arch Linux version, and I hope this will work on other Arch-based systems such as Antergos, Manjaro Linux etc. Available styles: Breeze, kvantum-dark, kvantum, Oxygen, QtCurve, Windows, Fusion xdg-mime: application argument missing Try ‘xdg-mime --help’ for more information. To set up GDM as your default display manager on Linux, you must first install it. Unlinking the the symlink and then enabling the service worked. jeff_story commented on 2014-11-09 04:33 gdm-old is broken when using gnome-keyring after version 3.10. Next step is to enable then start and test GDM by logging to Arch Linux using your credentials. Last edited by Bidski (2019-08-01 03:38:55), Please post the output of `systemctl list-unit-files --state=enabled` and `systemctl status gdm.service`, Arch + dwm   •   Mercurial repos  •   Surfraw, This is from after I started GDM and logged in via the GUI. We already have written about installing Budgie, Deepin, MATE DEs in Arch linux. Make sure that you're using Arch Linux. If it reports itself as ssuccessfully running, can you switch through all the virtual terminals and screens to see if it is just somewhere unexpected? In this case it is a symlink that points to /usr/lib/systemd/system/gdm.service. I've had an issue since upgrading from Fedora 14 to Fedora 16 in that after a while, and not on any trigger I've yet identified, my /var/log/messages starts filling up with: pulseaudio[pid]: protocol-native.c: Denied access to client with invalid authorization data. After some googling seems like I should be looking in /var/logs/gdm. Just got my Acer Aspire 1410 and decided to install Arch like on my previous laptop and this time I decided to use GNOME as desktop environment. 13. It supports theming, automatic login, and the automatic detection and use of multiple desktop environments. $ sudo pacman –S gdm. pacman -S gdm. The following instructions, however, only apply when using Xorg (else .Xauthority is not created, and x11vnc fails to start). This package needs to be updated because of the PAM changes in the Gnome GDM 3.36.3-6. I did check if the service is running, which it is. Author Message; Ruediger Ott #1 / 7. Just to check I didn't make a stupid mistake i tried to disable an enable the GDM.service while still on tty. Last edited by WonderWoofy (2013-06-29 20:37:45). Solution was to Unlink /etc/systemd/system/display-manager.service and the again enabling gdm service with systemctl enable gdm.serviceUnfortunately I was unable to identify the root cause for this problem. No log found. To your other questions: you should see gdm.service listed in your services output, yes. That's because that is systemd's default anyway. p.s. Help me a bit here: Shouldn't I see the GDM.service somewhere here? Eso jamas se T va a olvidar. Though the process is slightly straight forward. Nvidia 440.44- GDM Not starting on kernel 440.44 (Fedora 30) GPU Unix Graphics. We already have written about installing Budgie, Deepin, MATE DEs in Arch linux. If you compare your last output in #3 to mine in #2, yours shows graphical.target enabled (mine disabled; interestingly).edit: I just tried, enabling graphical.target did not matter in this case, it created the first symlink: Last edited by Strike0 (2013-06-30 00:51:32). After running and starting (seeing in ALT-F4 the Kernel … Linux (Arch) WPA_SUPPLICANT service not starting @ boot Helpful? Is systemd failing to start GDM because it is waiting for these non-existent services? systemctl start gdm.service systemctl enable gdm.service systemctl enable NetworkManager.service. I have installed GDM along with Gnome and I have enabled the GDM service, but GDM just doesnt start. Step 3: Reboot your Arch Linux PC using the systemctl reboot command. You need to enable the service with root privileges in order for systemd to set up the necessary sym links.